Domain logs contain many "Wrong context for address family" errors
book
Article ID: 332231
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Many errors are seen in the Smarts IP domain log as well as /var/log/messages similar to the following:
NX-E-WRONG_ADDRESS_FAMILY-Wrong context for address family (got AF_INET6, expected AF_INET). The given address family is supported by the operating system, but is being used in a way which is inappropriate or inconsistent.; in file "/work/tancurrent/DMT-9.0.4.0/11/smarts/clsapi/network/lib/NX_DualSocket.c" at line 242 PING-PINGER_EICMPECHO-Failure when sending icmp echo request.; in file "/work/tancurrent/DMT-9.0.4.0/11/smarts/icmp-accessor/pinger/ICMP_Poller.c" at line 147
The error does not appear to affect functionality or performance, but does place quite a few errors into the log files which can make it more difficult to review logs and support the affected domain.
Environment
Smarts 10.1.X
Cause
The above errors are caused by the default configuration of IPv6 polling in the default Smarts IP Polling groups when IPv6 is not being used.
Resolution
There are several instances Polling groups with the IPv6 option in the default configuration of Smarts IP Manager. If IPv6 is not being used in the environment, this error does not impact the environment and the IPv6 polling configuration can be removed. To do this, remove the "Connectivity Polling for IPv6 Addresses" from any Polling groups that have it configured as shown in the following screenshot. Once Connectivity Polling for IPv6 is removed from the configuration, the error messages will go away.