VMWare Smart Assurance VoIP-AM: Cisco Publisher CCM5+ is discovered in the VMWare Smart Assurance VoIP AM topology under VoipNetworkService instead of under CallManager; How can I discover it as a Call Manager?
search cancel

VMWare Smart Assurance VoIP-AM: Cisco Publisher CCM5+ is discovered in the VMWare Smart Assurance VoIP AM topology under VoipNetworkService instead of under CallManager; How can I discover it as a Call Manager?

book

Article ID: 332209

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:
How can I discover Cisco Publisher CCM5+ as a Call Manager in VMWare Smart Assurance VoIP?

Cisco Publisher CCM5+ is discovered in the VMWare Smart Assurance VoIP AM topology under VoipNetworkService instead of under CallManager.

Environment

VMware Smart Assurance - SMARTS

Cause

Call Manager process is not running on the Cisco Publisher.

Resolution

To discover the Cisco Publisher CCM5+ under CallManager and not VoipNetworkService, do the following:

  1. Open the cisco-ccm-publisher-probe.asl file in the following location using an appropriate editor:

    <BASEDIR>/VOIP/smarts/bin/sm_edit rules/voip/cisco/cisco-ccm-publisher-probe.asl

     
  2. Find line 68 that has the following:

    ccmPubClass         = "VoipNetworkService";
     
  3. Change line 68 to the following:
     
    ccmPubClass         = "CallManager";
     
  4. Delete the Publisher device from the VoIP Topology.
  5. Rediscover the Publisher in VMWare Smart Assurance IP AMPM.
  6. Verify that the Publisher is now discovered in VoIP under CallManager.