Smarts NPM: EIGRP Logs report "Too Many Authentication Failures for Smarts" for Nexus Devices
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Smarts NPM: EIGRP Logs report "Too Many Authentication Failures for Smarts" for Nexus Devices

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Article ID: 332204

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Nexus devices are reporting  "Too Many Authentication Failures for Smarts"  and disconnects.

Smarts generates EIGRP Session Disconnected or Down alerts that clear after 10 minutes and then regenerate later.  The alerts were similar to the ones below

EIGRP-ADJ-BXXX1-AGG/172.10.10.166<-->BXXX2-AGG/172.10.10.165    Disconnected

Upon researching the devices also reported the following messages: 

   [Device: BXXX1-AGG]: RESULT: [[[  
 Received disconnect from 172.xx.xx.xxx: 2: Too many authentication failures for smarts

  ]]]
  End of command output  :Received disconnect from 172.xx.xx.xxx: 2: Too many authentication failures for smarts

Environment

VMware Smart Assurance - SMARTS

Cause

The Nexus devices were configured with a very low timeout  --  tacacs-server timeout 1

Resolution

In this case the user account and password were correct and validated on the Nexus device. 

Enabling CLI Debug on the EIGRP domain, and running a PCAP between Smarts and the Device in question, pointed to a timeout issue.  

The resolution update timeout the Nexus device:

tacacs-server timeout 1
to 
tacacs-server timeout 10

Once this setting was saved, this change was reported to have resolved the issue.