Smarts SAM: Attempted to access undefined key '47' in table 'notifFields'
book
Article ID: 332196
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Reviewing the SAM log in an environment with OI and Notif in place, there are many errors like this one in the log files:
[October 18, 2017 1:19:27 PM GMT+00:00 +402ms] t@93316864 SAM-IP-NA-RED_NL-Driver_6 ASL-W-ERROR_RULE_SOURCE-While executing rule set '/opt/InCharge9/SAM/smarts/rules/ics/ics-nl-processing.asl' ASL-ERROR_ACTION-While executing action at: ASL-CALL_STACK_RULE- RuleName: processNLNotifyV2, Line: 2504 ASL-CALL_STACK_RULE- RuleName: NL_DELETE_V2, Line: 507 ASL-CALL_STACK_RULE- RuleName: PARSE_MESSAGE, Line: 479 ASL-CALL_STACK_RULE- RuleName: START, Line: 455 ASL-ERROR_UNDEFINED_TABLE_KEY_ACCESS-Attempted to access undefined key '47' in table 'notifFields' ASL-BAD_HASH_TABLE_INDEX-The index '47' is out of bounds
Environment
VMware Smart Assurance - SMARTS
Cause
This exception occurs when the logic searches for a device that has already been deleted from the topology. The issue is cosmetic and doesn't interrupt normal operation of the SAM.
Resolution
Issue is cosmetic, however has been fixed in Smarts 9.5.