Smarts Alcatel Adapter: login failure; Adapter is not getting valid response to the version request , </faultcode><faultstring>[security]Login Failure
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Smarts Alcatel Adapter: login failure; Adapter is not getting valid response to the version request , </faultcode><faultstring>[security]Login Failure

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Article ID: 332178

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


User is getting a login error as follows:  However Smarts ASAM5620 Adapter 3.6.0.7 and all credentials are configured correctly.


 [February 9, 2016 12:03:41 PM GMT+01:00 +995ms] t@3854526208
ASAM_MESSAGE-*-WARNING-.[MessageToEventConverter] JMS active server is 10.10.11.11

[February 9, 2016 12:03:42 PM GMT+01:00 +020ms] t@3853473536
ASAM_MESSAGE-*-SEVERE-.[Connector] SmAsAlarmEmsInterface::checkEmsVersion got SmIciException : com.smarts.agLib.icInterface.SmIciException: Adapter is not getting valid response to the version request -
<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"><SOAP:Header><header xmlns="xmlapi_1.0"><requestID>ionix@12345</requestID><requestTime>Feb 9, 2016 12:03:42 PM</requestTime><responseTime>Feb 9, 2016 12:03:42 PM</responseTime></header></SOAP:Header><SOAP:Fault><faultcode>SOAP:Client</faultcode><faultstring>[security] Login failure.</faultstring><faultactor>XmlApi</faultactor><detail><requestID>ionix@12345</requestID></detail></SOAP:Fault></SOAP:Envelope>

[February 9, 2016 12:03:42 PM GMT+01:00 +021ms] t@3853473536
ASAM_MESSAGE-*-SEVERE-.[Connector] Exception Type:com.smarts.agLib.icInterface.SmIciException Adapter is not getting valid response to the version request -
<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"><SOAP:Header><header xmlns="xmlapi_1.0"><requestID>ionix@12345</requestID><requestTime>Feb 9, 2016 12:03:42 PM</requestTime><responseTime>Feb 9, 2016 12:03:42 PM</responseTime></header></SOAP:Header><SOAP:Fault><faultcode>SOAP:Client</faultcode><faultstring>[security] Login failure.</faultstring><faultactor>XmlApi</faultactor><detail><requestID>ionix@12345</requestID></detail></SOAP:Fault></SOAP:Envelope>
com.smarts.asac.SmAsAlarmEmsInterface.checkEmsVersion(SmAsAlarmEmsInterface.java:1108)
com.smarts.asac.SmAsAlarmEmsInterface.jmsConnect(SmAsAlarmEmsInterface.java:479)
com.smarts.asac.SmAsAlarmEmsInterface.jmsConnect(SmAsAlarmEmsInterface.java:472)
com.smarts.asac.Connector.run(SmAsAlarmEmsInterface.java:1461)


The SAM Server shows following logging which indicates smarts as password:

userName=smarts;
message=Wrong password: 'smarts';


Environment

VMware Smart Assurance - SMARTS

Cause



The issue here is that the credentials in the emsConfig.import are correct but the password was not hash MD5 encrypted:

e.g. 
<BASEDIR>/ASAM/smarts/local/conf/emsConfig.import:


EmsInstance= {
        {
            "10.10.11.11",
            "8080",
            "smarts",
            "changeme"
        }




Resolution

When configuring the Adapter,  the MD-5-hashed version of the password for the Alcatel-Lucent 5620 SAM EMS must be added to the EmsInstance and AltEmsInstance of the emsConfig file as follows:

Generate an MD-5 hashed password:

Create an MD-5 hashed version of the password for each Alcatel Lucent 5620 SAM EMS server. To convert a clear text password string:
1. Open a command tool or shell on the Alcatel Lucent 5620 SAM EMS server
2. Go to the <install dir>/nms/bin directory, where <install dir> is the server installation directory
3. Convert the password as follows:
  mdhash.bash <password string>
4. Using sm_edit, edit the <BASEDIR>/ASAM/smarts/local/conf/emsConfig.import: file.
5. Copy and paste the resulting MD-5 hashed password string to the password area of the EmsInstance and AltEmsInstance of the emsConfig file
6. Restart the Alcatel Lucent 5620 SAM EMS server.

Additional Information

For more detail please refer to "Generating an MD-5-hashed password" on page 38 of the Alcatel Lucent 5620 SAM EMS server version 3.2 User Guide. Also please reference Table 1 is this document which explains the entries in the emsConfig.import file.