DiscoveryLastAt does not change or not updated during rediscovery or new discovery.
search cancel

DiscoveryLastAt does not change or not updated during rediscovery or new discovery.

book

Article ID: 332170

calendar_today

Updated On:

Products

VMware Smart Assurance VMware Telco Cloud Service Assurance

Issue/Introduction

  • Smarts IP Discovery will not complete for all devices. 
  • Any updates in devices will not show in Smarts IP.
  • Manually rediscovering device(s) through console and command line do not finish/complete.

Environment

Smarts - 10.1.x

TCSA - 2.x

Cause

The RPS file is corrupted. In environments where this issue is seen, both the probeInProgress attribute and the DiscoveryInProgress attribute may be set to FALSE for devices during discovery. This condition should not happen normally during discovery, but is happening because the RPS file is damaged/corrupted.

Resolution

  1. Dump the seed file following KB: Creating a seedfile from an existing topology
  2. Shut down the Smarts IP domain.
  3. Rename/move the RPS file.
  4. Start the IP domain with the --clean-topology argument, refer to KB: Using --clean-topology switch for sm_server command to preserve domain settings but remove all monitored devices.
  5. Use the seedfile to run the discovery Discover devices using a seed file via command line and GUI.