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Article ID: 332167
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Issue/Introduction
Symptoms:
The user is currently addressing an existing issue of Interface/Port Down alarms before sending them to their console.
They see the following notifications below:
ICS_Notification::NOTIFICATION-Port_PORT-aaa-bbb.ccc.ddd.com/444_Down
ICS_Notification::NOTIFICATION-Port_PORT-aaa-bbb.ccc.ddd.com/555_Down
User was informed that these alarms should not be occurring because the interfaces were Admin down. User reviewed the SNMP and physical interfaces were Admin down and the sub-interfaces were lowerLayerDown.
However, when inspected from the Smarts console, the device in question did not have any discovered relationship between the physiccal interfacce and the sub-interface.
User verified the Juniper device does support the MIB and the data appeared to be correct.
When turned on debug and rediscover the device, we can see that the ic-ifmib-stack.asl was being called and returned valid data:
December 13, 2017 11:14:25 PM GMT+00:00 +662ms 1951114 3389994752 ALWAYS Discovery #10 ASL_MSG-ASLP discovery/ic-ifmib-stack.asl: discovery/ic-ifmib-stack.asl: MIB2_IFSTACK: aaa-bbb.ccc.ddd.com
December 13, 2017 11:14:25 PM GMT+00:00 +662ms 1951115 3389994752 ALWAYS Discovery #10 ASL_MSG-ASLP discovery/ic-ifmib-stack.asl: .1.3.6.1.2.1.31.1.2.1.3.[444.222] = 1
December 13, 2017 11:14:25 PM GMT+00:00 +663ms 1951116 3389994752 ALWAYS Discovery #10 ASL_MSG-ASLP discovery/ic-ifmib-stack.asl: discovery/ic-ifmib-stack.asl: MIB2_IFSTACK: aaa-bbb.ccc.ddd.com
December 13, 2017 11:14:25 PM GMT+00:00 +663ms 1951117 3389994752 ALWAYS Discovery #10 ASL_MSG-ASLP discovery/ic-ifmib-stack.asl: .1.3.6.1.2.1.31.1.2.1.3.[555.333] = 1
The correct behavior should be that if the physical interface is admin down, the sub-interface should not be alarming, but it is.
User set the EnableMIB2PortDiscovery flag to TRUE. Initial discovery discovers the correct interface/port relationship. However, after the second and so on discovery, the physical port/interface is removed.
Environment
VMware Smart Assurance - SMARTS
Cause
A problem with history table handling
Resolution
Issue is addressed in the IP 9.5.0.4 version of the ic-juniper-mib-port.asl