Smarts SAM / IP: System clock error: LIC-EFLEXLM-FlexLM returned the following error message: "System clock has been set back; FLEXnet Licensing error:-88,309.
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Article ID: 332161
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Cannot start Smarts Server(s)
Environment
VMware Smart Assurance - SMARTS
Cause
The error is usually seen when there are files on the system that are dated in the future.
Flexlm is a third party software product that generates this error. The information from Flexlm is that error is caused when the system clock has been changed, but its unclear what the behavior will be after the clock is changed back making it a difficult issue to troubleshoot. We do know however, that Flexlm is very unforgiving when it comes to any changes to the system be it the license server or the system clock.
Resolution
The following remedies have worked for different instances of this issue:
1. The system clock has been set back and files are out of sync - Please check the system clock is indeed correct (todays date and time) [Ketan] :- The date is correct here root@aps003a008 # date Friday September 26 13:51:03 BST 2014
2. There are files on the system which are not in sync with the system clock i.e. they are dated in the future. The error can be thrown if files are more than 24 hours ahead of the system clock.
If so, run the following command to see if there are files dated more than 24 hrs ahead of the system clock: >cd / >touch t <mmddhhmm> temp Where the <mmddhhmm> is one day ahead e.g for today it would be 09271300 (1 pm on the 27th Sept) e.g > cd / > touch -t 09271300 temp Then run the command : > find . -newer temp \! -type f | more ->newer.txt
Check the contents of newer.txt and change the dates to todays date.
3. If your license server is running on a different client to the Smarts server, the client and server may not have the same time please check that both client and server have the same time.
4. License has the wrong path. Ensure that the license file is located in the path specified in the License path that is indicated in the error. If this is not the intended path to the license file, edit the SM_LICENSE environment variable in the Smarts runcmd_env.sh file to point to the correct location of the license file.
5. Corrupt file in /tmp Remove the contents of the /tmp directory
6. Corruption with the license file. Request a fresh license from the Licensing team and reinstall.
7. An issue with the OS, if all of the above have been tried then if possible, reinstall the OS.