Smarts IP/SAM: Unable to run the sm_service show tool. SMS-E-CLI_ENOPIPE-Cannot connect to sm_serviced. Are you sure it is running?
search cancel

Smarts IP/SAM: Unable to run the sm_service show tool. SMS-E-CLI_ENOPIPE-Cannot connect to sm_serviced. Are you sure it is running?

book

Article ID: 332138

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


When trying to run the sm_service show command, the following error is being returned: SMS-E-CLI_ENOPIPE-Cannot connect to sm_serviced. Are you sure it is running?

Environment

VMware Smart Assurance - SMARTS

Cause

The sm_serviced has stopped or not running 

Resolution

1, Determine if any other EMC Smarts processes are still running and stop them.
Detect the processes using the following commands:

ps -ef | grep  sm_ 

If a list is displayed, (for example, sm_server, sm_notify, sm_adapter, sm_beacon, sm_tomcat, brstart, etc.), note the process ID (pid) of these active EMC Smarts processes.

Note: Do not shutdown any sm_authority or sm_logger processes The sm_authority and sm_logger processes are child processes of an EMC Smarts server. The child processes will stop when the parent process stops.

2, Shut down these EMC Smarts processes using the following command:
kill -9 <pid>

3, Stop the EMC Smarts service daemon using the sm_service utility from BASEDIR/smarts/bin. 
<path>/ic-serviced stop

<path>/ is system-specific.
  • Solaris: /etc/init.d
  • Linux: /etc/init.d
  • HP-UX: /sbin/init.d
4, Start the service daemon
<path>/ic-serviced start