Smarts SAM 9.0 or earlier: Server connection is getting reset; Notification Console will not stay connected to server; Issue with "Keep Alive" messages using TCP flag/pointer
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Smarts SAM 9.0 or earlier: Server connection is getting reset; Notification Console will not stay connected to server; Issue with "Keep Alive" messages using TCP flag/pointer

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Article ID: 332123

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts SAM server cannot maintain connection to Notification Console application





Smarts SAM server cannot process the Keep-alive connection message correctly, so the connection to the application such as the Notification Console to the server is reset.

Environment

VMware Smart Assurance - SMARTS

Cause

Smarts SAM 9.0 and earlier versions use Keep-alive-messages which use the TCP Urgent Flag/Pointer to signal an immediate processing of the packets to the servers/routers. Since this flag can be a serious security risk, most firewalls drop/modify those packets so that the Smarts SAM server cannot process the newly modified message. The connection to the server then gets reset.

Resolution

If you encounter this issue, EMC Smarts Customer Service (CS) recommends upgrading your environment to Smarts SAM 9.1 or later. The connectivity functionality for Smarts SAM applications was changed in Smarts SAM 9.1 and later versions. Smarts SAM 9.1 and later use an in-band keepalive mechanism that uses a SM_NO_TLS variable which does not use an Urgent flag and is not an issue with firewalls. 

IMPORTANT! Both the Smarts SAM server and Smarts application (Notification Console) must be at version 9.1 or later to use this functionality, or the environment will default back to using the pre-9.1 keepalive functionality.


Additional Information

See the Smarts SAM 9.1 System Admin guide for more details on the variable functionality.