Smarts ESM 9.4: Application tab not getting populated; Error from ESM Log file: snmp_get_processes.asl: Duplicate found: ConfiguredProcName <Process_Name>
book
Article ID: 332088
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Applications not being populated on SNMP process monitoring host.
Process selected and configuration saved:
No application tab listed as no applications created:
Error from ESM Log file:
snmp_get_processes.asl: Duplicate found: ConfiguredProcName: <My_Process> DuplicateProcName: <My_Process> snmp_get_processes.asl: gotExistingConfig: TRUE snmp_get_processes.asl: Finished building host process monitoring config table for host <My_Host> (got snmp+got config object) sp-pre-get-processes@1649407744: has ended for: SNMPAgent-<My_Host>
Environment
VMware Smart Assurance - SMARTS
Cause
The procTable keeps track of monitored processes in Smarts ESM.
On occasion, this procTable might get corrupt and the information in the procTable does not match the information displayed when the user selects Configure Process Monitoring for a host.
Resolution
Please run the following dmctl commands to reset the procTable for a specific host in Smarts ESM:
Step 1 (Replace <HostName> with actual host in question):
Login to the Smarts Console GUI and attach to the ESM domain. Right click on the host and select Configure Process Monitoring. You should now be able to configure process monitoring as normal using the GUI.