Smarts SAM: SAM/OI domain stops consistently and will not stay running when loading an existing RPS on Windows, with no errors seen in the Smarts log but buffer overflow exception seen in Windows Event Log.
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Smarts SAM: SAM/OI domain stops consistently and will not stay running when loading an existing RPS on Windows, with no errors seen in the Smarts log but buffer overflow exception seen in Windows Event Log.

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Article ID: 332027

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts SAM or OI service cannot stay running for a stable period of time, which makes the services non-functional.

The following conditions, events or system behaviors may be observed with this issue:
  • Smarts SAM/OI domain stops on loading an existing RPS on Windows with no errors in the Smarts logs.
  • Smarts SAM/OI domain crashes consistently on loading an existing RPS on Windows environment, and Windows Event logs indicate buffer overflow exception.
  • Windows Event Viewer may reflect that an Application Error similar to the following:
Log Name:      Application
Source:        Application Error
Date:          11/1/2013 2:07:33 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      mars.local
Description:
Faulting application name: sm_server.exe, version: 0.0.0.0, time stamp: 0x51975be6
Faulting module name: sm_ics_ems.dll, version: 0.0.0.0, time stamp: 0x51a74e69
Exception code: 0xc0000409
Fault offset: 0x00000000004d2a38
Faulting process id: 0x1070
Faulting application start time: 0x01ced72d07813113
Faulting application path: C:\InCharge921\SAM\smarts\bin\system\sm_server.exe
Faulting module path: C:\InCharge921\SAM\smarts\lib\sm_ics_ems.dll
Report Id: 7a43d227-4320-11e3-927f-005056b0004f


Environment

VMware Smart Assurance - SMARTS

Cause

The above issue is caused by a software functional issue related to the sm_ics_ems.dll file that is unique to Smarts SAM 9.2.1 in Windows environments.

Resolution

There is no current or planned resolution for this issue in Smarts SAM 9.2.1.  To address this issue, you must do either of the following:
  • Upgrade to Smarts SAM version 9.2.2 where the issue has been addressed.
  • If feasible depending on your local Disaster Recovery plan, roll the system back to the previous Smarts SAM installation version before the upgrade to 9.2.1.


Additional Information

More information about this issue can be found in the Smarts SAM 9.2.2 Release Notes (PDF attached to this article), at the bottom of Page 67 in the table entry that references CQ 605417.