Smarts: I changed the password for EDAA from the default via sm_edit but its not encrypted; Why is the EDAA password not being encrypted after its changed.
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Smarts: I changed the password for EDAA from the default via sm_edit but its not encrypted; Why is the EDAA password not being encrypted after its changed.

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Article ID: 332015

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




When editing the edaaClientConnect.conf file via sm_edit so the default password can be changed and encrypted, the password is still shown in clear text.


At the very last line of the file you can see the password is still in clear text.


Environment

VMware Smart Assurance - SMARTS

Cause

The edaaClientConnect.conf file located in the Smarts <Basedir>/conf directory does not have the necessary line which enables the password to be encrypted when changed via sm_edit.


Example:

       First line of the edaaClientConnect.conf        vs.       the clientConnect.conf

Resolution

As a work around you can edit the edaaClientConnect.conf file, which will be located in:

Smarts <Basedir>/conf folder 

If it has been previously edited, it will be located in:

Smarts <Basedir>/local/conf folder

Please be sure you edit with sm_edit, which is located in Smarts <Basedir>/bin


example of running sm_edit:

#./sm_edit ../edaaClientConnect.conf

1- Add the following to the top line- <encrypted field>:1.0:4

2- Change the password on the last line

3- Save and exit

Now when you view the edaaClientConnect.conf file you'll see the encryption check on the 2nd line.


And on the last line you'll see your password is now encrypted. 


This is scheduled to be fixed in an upcoming patch for Smarts 9.3.x