Smarts ESM: Getting unreachable events from the VMwareDatastore; objectVMwareDatastore not reachable notification does not clear
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Article ID: 332014
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Customer indicated that they are getting unreachable events from the VMwareDatastore object. When an ESX host is rebooted, Smarts generates a notification that states the VMwareDatastore for that server is not reachable. When the ESX host returns to service, the event does not clear automatically. Looking at the attributes of the datastore in Server Manager we see IsAccessible=FALSE. When we manually reset the attribute to IsAccessible=TRUE the notification clears. Why is this not automatic?
Environment
VMware Smart Assurance - SMARTS
Cause
The value for "IsAccessible" is being polled from vCenter. It is possible that when the ESX host was rebooted, it had a problem polling the value from the vCenter.
Resolution
The rediscovery of the ESX host should update the IsAccessible value and clear the event. If one still observes this issue after the rediscovery, please gather the following information:
1. Send support a screen shot of the event from the SAM notification log console including event 2. Send support a screen shot for the VM and for the Datastore object in question. 3. Send support a copy of the ESM domain rps and domain log.