VMWare Smart Assurance: Log contains "CI-W-SPOOL_PKG-Error" and extreme memory growth observed on server
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VMWare Smart Assurance: Log contains "CI-W-SPOOL_PKG-Error" and extreme memory growth observed on server

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Article ID: 331999

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:
Log for VMWare Smart Assurance application (SAM/IP/VoIP/NPM) environment contains CI-W-SPOOL_PKG-Error and extreme memory growth observed on server
Errors similar to the following are repeatedly observed in the VMWare Smart Assurance SAM/IP/VoIP/NPM log file:

CI-W-SPOOL_PKG-Error occurred while spooling package data for 'mrerror346c9b5a'



Memory growth is observed to steadily increase on the VMWare Smart Assurance SAM/IP/VoIP/NPM server, often resulting in a core dump

Environment

VMware Smart Assurance - SMARTS

Cause

This error is generated when the VMWare Smart Assurance (SAM/IP/VoIP/NPM) environment is deployed using SM_WRITEABLE and SM_SITEMOD and is caused by a failure to create required directories.

The directory where DMT client and server components look for messages bundles SM_SITEMOD/l10n. The directory where the DMT client library stores message bundles (*.dat files) transferred to it by the DMT server is SM_WRITEABLE/l10n/spool. The DMT packaging and installation ensures that "l10n/spool" exists in the default SM_SITEMOD location in order to separate client local bundles from those transferred by a server. Failure to create the correct directories will result in repeated error messages being logged as well as constant memory growth that will eventually use all available memory and result in a crash. 

NOTE: if the directory is not there, you should add it.  Not all smarts servers that show this error in the log are using the SM-SITEMOD and SM_WRITEABLE. 

Resolution

If you encounter this issue in your environment, verify/ensure that "l10n/spool" exists as a subdirectory in the directories listed in SM_WRITEABLE.