Smarts SAM: Hosts are not found when using Find System option in Smart Console even if the systems are listed in the repository; Error: "No Instance Found"
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Smarts SAM: Hosts are not found when using Find System option in Smart Console even if the systems are listed in the repository; Error: "No Instance Found"

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Article ID: 331997

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Find System functionality in Smarts Console not working consistently

Find System functionality in Smarts Console not working consistently.

Error: "No Instance Found"


Environment

VMware Smart Assurance - SMARTS

Cause

Search uses findInstance operation against SM_System class in underlying Smarts IP domain.
findInstance function is trying to resolve specified name to IP address to uniquely identify your system which fails in the device.

To check,  please execute the command from server where IP domain is running:

<IP>/bin/dmctl -s <IP Domain> invoke SM_System::SM-System nameToAddr <device name>

The command should return an IP address of  the <device name>. If it can't resolve the name to the address resolution,  it will get the error:

"Instance not found"


Resolution

DNS Resolution issues in user environment.
Device name is not resolving to an IP address of the host running in the Smarts IP Domain.

In this case the device name and IP address need to be added to the DNS server or using local name resolution. Depending on OS type, please edit and add them to the following:

unix
/etc/hosts file

Windows
<%Win%>\system32\drivers\etc\hosts file