Smarts IP: How can I limit the number of IP addresses in the Smarts IP AgentAddressList?; Device went down in the Smarts IP domain but no notification was received
search cancel

Smarts IP: How can I limit the number of IP addresses in the Smarts IP AgentAddressList?; Device went down in the Smarts IP domain but no notification was received

book

Article ID: 331973

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


How can I limit the number of IP addresses in the Smarts IP AgentAddressList?

Device went down in the Smarts IP domain but no notification was received

Environment

VMware Smart Assurance - SMARTS

Cause

The Smarts IP domain monitors devices through their IP addresses in the SNMPAgent object's AgentAddressList. The above symptom can be seen because some of these IP addresses may be duplicates used for shared IP addresses, as in a cluster environment. This can cause the Smarts IP domain to ping/poll the wrong device, which in turn can cause notifications to be generated incorrectly.

Resolution

The Smarts IP domain will limit the number of IP addresses in the AgentAddressList for the SNMPAgent object to poll.  By default, this limit value is 10. The following sections of this Fix statement explain how to change this limit value temporarily or permanently.

Temporarily changing the IP address limit in AgentAddressList
The following command  (all on one line) shows how to change the IP address limit setting dynamically to 1, so that only one IP adddress is returned from the AgentAddressList:

<BASEDIR>/smarts/bin/dmctl -s <AM domain> put ICF_TopologyManager::ICF-TopologyManager::MaxNumberOfAgentAddresses 1

This change will take affect right away, but you will need to rediscover the device in Smarts IP to apply the change in the domain.

Permanently changing the IP address limit in AgentAddressList
To permanently change the IP address limit used by Smarts IP, do the following:

  1. Open the Smarts discovery.conf configuration file for editing using the Smarts sm_edit tool.
     
  2. Add the attribute "MaxNumberOfAgentAddresses  = 1" into the file.
     
  3. Save and close the discovery.conf configuration file.
     
  4. Restart the Smarts IP domain for the change to take affect.