Smarts Server Manager(ESM): VMs not rediscovered in Smarts ESM after maintenance period; VM objects are recreated in ESM but not rediscovered; VMs not re-imported into Smarts IP.
search cancel

Smarts Server Manager(ESM): VMs not rediscovered in Smarts ESM after maintenance period; VM objects are recreated in ESM but not rediscovered; VMs not re-imported into Smarts IP.

book

Article ID: 331932

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


VMs not rediscovered in Smarts ESM after cluster maintenance period; VM objects are created in ESM but not rediscovered

After placing two VM clusters into maintenance mode, Smarts ESM removes a number of VM s from ESM and Smarts IP. After the clusters were taken out of maintenance mode, VM objects was created in ESM the VM s were not rediscovered and not re-imported to the Smarts IP server.

Environment

VMware Smart Assurance - SMARTS

Cause

Settings in the vmware-pushto-ip.asl file. Specifically, it is the snmpSource attribute which is causing the reported issue


Resolution

This is a known issue and will be fixed in a future release.

The following workaround is available:
 
  1. Navigate to the following directory to find the vmware-pushto-ip.asl file:
    1. <Basedir>/ESM/smarts/rules/vmware
  2. Using sm_edit, open the vmware-pushto-ip.asl and find the below portion. You will want to change the line below in bold:
    1. topo_manager->addPending(vmIP, //nameOrAddr
      "public", //community
      "Virtual Machine", // description
      "TM_DISCOVERED", // snmpSource   
      "TM_SNMP", // snmpState
    2. Change TM_Discovered line to read: "TM_USERADDED", // snmpSource
  3. After making the change to the vmware-pushto-ip.asl file, and saving the file, the issue should no longer be seen. If the VM s are still not re-imported into AMPM from ESM, please contact support and provide the base, and local, copies of the vmware-pushto-ip.asl file.


Additional Information

Miscellaneous Notes:
- Modifying the vmware-pushto-ip.asl file has seen the issue resolved in Smarts ESM versions 9.2.1.1, 9.3, 9.3.0.2, and 9.4.0.1
- It is recommended that you try this fix in a test environment first, before making changes in production.
- If you have devices that are excluded via polling groups in your ESM domain, these devices may show up after making this change. Before making the change to the asl file, you may want review your IP discovery filters and exclusion list in the IP discovery.conf file.