Smarts IP: Unable to rediscover device; Rediscover option greyed out; Error: While invoking operation rediscover in object 'ICF_TopologyManager::ICF-TopologyManager', Tried to make a call on a NULL repository object
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Smarts IP: Unable to rediscover device; Rediscover option greyed out; Error: While invoking operation rediscover in object 'ICF_TopologyManager::ICF-TopologyManager', Tried to make a call on a NULL repository object

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Article ID: 331884

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


No longer able to rediscover devices

The rediscover button greyed out and devices can no longer be rediscovered

Even if you try to use dmctl to do a rediscover of a device the issue still occurs:
/opt/InCharge81/SAM/smarts/bin/dmctl -s IP invoke ICF_TopologyManager::ICF-TopologyManager rediscover Router::routers-name
Server IP User: admin
admin's Password: XXXXXXXXXX
MR2-E-MR_WHILE_OPERATION_INVOKE-While invoking operation rediscover in object 'ICF_TopologyManager::ICF-TopologyManager'
 MR-OBJECT_NOT_FOUND_EX-Cannot find object 'ICF_TopologyManager::ICF-TopologyManager'
 MR-CALL_ON_NULL_OBJECT-Tried to make a call on a NULL repository object; in file "/work/tancurrent/DMT-9.0.4.0/11/smarts/repos/servif/SM_RepositoryServer.c" at line 1096
 


Environment

VMware Smart Assurance - SMARTS

Cause

Corrupt repository file

Resolution

The cause of this issue in this particular case was corruption of the rps file

The user reverted to a backed up copy of the rps file by following these steps(in this example, the Smarts IP domain has the default name: INCHARGE-AM-PM) :

1.) Stop the INCHARGE-AM-PM service:

./sm_service stop INCHARGE-AM-PM

2.) Replace the corrupt rps file with the backed up copy.

RPS file is located at:

<InstallDir>/smarts/local/repos/icf/

3.) Start the INCHARGE-AM-PM service:

./sm_service start INCHARGE-AM-PM