VMWare Smart Assurance SAM: Service Assurance Manager (SAM) is not completing a topology sync with the underlying domain manager
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VMWare Smart Assurance SAM: Service Assurance Manager (SAM) is not completing a topology sync with the underlying domain manager

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Article ID: 331869

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:
VMWare Smart Assurance Service Assurance Manager (SAM)  is not completing a topology sync with the underlying domain manager
Connected VMWare Smart Assurance SAM consoles become unresponsive

Topology sync with underlying VMWare Smart Assurance Service Assurance Manager (SAM) domain does not complete

Environment

VMware Smart Assurance - SMARTS

Cause

Output of the following command run against VMWare Smart Assurance Service Assurance Manager (SAM)  domain shows several threads waiting to perform topology sync:
dmctl -s <domain> exec dmdebug --threads

Resolution

This problem can occur for a variety of causes. To assist in resolving this issue, VMWare Smart Assurance introduced the ability to stop connections to underlying domains if the domain is busy and unresponsive.  To take advantage of this functionality, do the following:

  1. Add the following lines to the appropriate DXA files present in presentation SAM, Aggregation SAM and OI server:

    TimeOutTopo 600 // this prevents toposync operations waiting indefinitely and sets a 10 minute (600 seconds) timeout limit;

    TimeOutBE 600  // this prevents event and NL driver operations waiting indefinitely and sets a 10 minute (600 seconds) timeout limit;

     
  2. Run a reconfigure operation to apply these settings in the active VMWare Smart Assurance SAM environment.