Smarts Failover: Failover initiated to Site_B after changing the admin password in the clientConnect.conf file; Error: Login to Domain Manager failed; permission denied; What is the correct procedure for changing the admin password?
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Smarts Failover: Failover initiated to Site_B after changing the admin password in the clientConnect.conf file; Error: Login to Domain Manager failed; permission denied; What is the correct procedure for changing the admin password?

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Article ID: 331865

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Failover initiated to Site_B after changing the admin password in the clientConnect.conf file. 

Failover started and ran correctly until user attempted to change the admin password.

Now when the domains are started (all Smarts domains, followed by Failover domain), Smarts IP, MPLS and NPM domains on the A side start as Standby and the B-side start as Active.

 InCharge Framework
SVIF-W-ESERVERCONNECT-While attempting to (re)connect to the remote server 'server1'
SM-ELOGIN-Login to Domain Manager failed; permission denied; in file "/work/tancurrent/DMT-9.2.2.X/3/smarts/skclient/servif/SM_Broker.c" at line 420

Environment

VMware Smart Assurance - SMARTS

Cause

The Smarts Failover Manager will pick up the first matching entry in clientConnect.conf file, which is usually admin.
If the admin password has been changed in the clientConnect.conf and not in the serverConnect.conf files for the underlying domains, this may trigger a failover to site B.

Resolution

Incorrectly changing the clientConnect.conf file will cause authentication issues between the Smarts Failover Manager and underlying domains and may initiate a failover to Site_B.

You need to ensure that the entry in the clientConnect.conf file that is being used by the Smarts Failover Manager matches the serverConnect.conf file that the managed domains are using.

Please use the following procedure:
  1. Stop the Smarts Failover Manager.
  2. Stop all the managed domains.
  3. Update the clientConnect.conf file in the Smarts Failover install directory with the new password. Please ensure that sm_edit is used.
  4. Update the serverConnect.conf file in the managed Smarts domains install directories with the new password. Please ensure that sm_edit is used.
  5. Start Smarts domains again and ensure it is possible to connect via dmctl or the console GUI with the new password.
  6. Start the Smarts Failover Manager.