SMARTS SAM: Hierarchical groups not appearing in console after importing from template file; How to check the status of the import driver (GA_DaemonDriver::ICS-Group-Driver)?
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SMARTS SAM: Hierarchical groups not appearing in console after importing from template file; How to check the status of the import driver (GA_DaemonDriver::ICS-Group-Driver)?

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Article ID: 331817

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Hierarchical groups not appearing in console after importing from template file

User has created a new template file containing group definitions and attempting to import via the GA_DaemonDriver::ICS-Group-Driver. However, groups are not appearing in the console.

Environment

VMware Smart Assurance - SMARTS

Cause

GA_daemondriver was stuck in pending_stop state, hence not processing new .template file

Resolution

To determine the status of the GA_DaemonDriver, run the following command from the <SMARTS>/bin directory:

./dmctl -s <DOMAIN> get GA_DaemonDriver::ICS-Group-Driver
Properties of GA_DaemonDriver::ICS-Group-Driver:
    CreationClassName = GA_DaemonDriver
                 Name = ICS-Group-Driver
       ReadsInputFrom = <Null Object>
       ReadsRulesFrom = GA_RuleSet::ICS-Group-Driver-RS
       SendsActionsTo = <Null Object>
          ServiceName =
    enableLegacyPrint = FALSE
     enableStackTrace = FALSE
            isRunning = FALSE
                state = <>

              timeOut = 0
                trace = FALSE
            variables = {  }
           verifyOnly = FALSE
    waitForCompletion = FALSE


The two lines marked in bold will indicate if the driver is running, and what is it's current state.

If the driver is stuck in pending_stop, use the following commands to restart driver:

dmctl -s <DOMAIN> invoke GA_DaemonDriver::ICS-Group-Driver stop
dmctl -s <DOMAIN> invoke GA_DaemonDriver::ICS-Group-Driver start

Additional Information

If you cannot restart a running GA_DaemonDriver using the stop/start commands, it is likely hung for some reason. If so, you will need to restart your domain.