Smarts: NPM Discovery of BGP Sessions does not appear to match information from snmpwalk
search cancel

Smarts: NPM Discovery of BGP Sessions does not appear to match information from snmpwalk

book

Article ID: 331813

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


This is not a common issue to have stale BGP sessions in NPM.  If this is the issue BPG Sessions that are stale and not actually present will generate alerts.  In this scenario, we had one device presenting the issue.  

In this scenario, we had one device generating unexpected or false BGP Session alerts.



Environment

VMware Smart Assurance - SMARTS

Cause

Stale entries in the BPG sessions for the device were not removed in BGP Post processing.

Resolution

Use the sm_snmpwalk utility to check the device in question with regards to the bgpPeerLocalAddr MIB.

The -o option changes the root OID of the walk to the relevant MIB: 

./sm_snmpwalk -s 2c -c <community string> -o .1.3.6.1.2.1.15.3.1.1 <DeviceName or IP Address>

Review the output:

If the output from the above command does not match the number of BGP Sessions discovered in NPM then you can do the following steps to rediscover the device:   

1. Remove the device from the Smarts IP server (right click on the device and delete).
2. Click Reconfigure button in Smarts IP (located on the menu bar). 
3. In Smarts NPM (BGP), select Topology -> Discover All. 
4. Wait for the completion of discovery task. 
5. Add the device again to the Smarts IP server. 
6. Do anothe Discover All in Smarts NPM (BGP) server.

This should resolve any stale entries for BGP Sessions in the NPM domain