Troubleshooting SAM Console Startup Issues
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Troubleshooting SAM Console Startup Issues

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Article ID: 331812

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

This article contains ideas on how to troubleshoot the SMARTS Java Console User Interface issues.

Environment

Smarts 10.X

Cause

Some environmental settings on a Windows host may prevent the console from running.

Resolution

1: To enable debug logging, follow these steps:

  • On your windows machine, run the command line using the "Run a administrator"  option.
  • Navigate to the <installed base>/smarts/bin folder and run this command
sm_edit ..\conf\console\properties.conf
  • Append these comments to the file:
com.smarts.log.level=TRACE
com.smarts.longOperation=1
com.smarts.debugConnection=true
com.smarts.java.log=console.log
  • NOTE: Using sm_edit will ensure the new file gets saved in the proper  \local\conf\console folder.

The log will appear in the <base_dir>/smarts/local/logs folder as console.log.

2: To check that the java security settings are correct, follow these steps. 

  • Start theControl Panel -> Program->Java->Advanced.
  • Scroll down to check "Mixed code (sandboxed vs. trusted) security verification" is set as "Disable verification (not recommended)".
  • Note: Without this setting, the webconsole won't work properly and the cmd prompt won't be brought up after the client tool is launched.

3: To make sure the DNS is setup properly on the machine.  It is necessary to be able to resolve the host name  without the suffix.  So if your fully qualified domain name is free.mycomputer.com, you need to able to ping just the hostname: free.

  •  You  can configure its DNS suffix list via Advanced TCP/IP Settings via Local Area Connection Properties of Local Area Connection Status.