Smarts SAM/IP: Failover Manager does not invoke reconfigure after backup; Polling and threshold changes are not present on secondary Smarts IP domain following failover
book
Article ID: 331809
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Polling and threshold changes are not present on secondary Smarts IP domain following failover
Following a failover, the secondary server becomes the primary server. However, in this case, it was observed that changes made to the primary server prior to the failover had not been copied across.
Environment
VMware Smart Assurance - SMARTS
Cause
If the components listed in the failover.conf file are not up and running during the Smarts Failover Manager startup, then the Failover Manager marks them as Unmanaged.
If the components are UnManaged in the Failover Manager, a reconfigure following failover does not take place.
Resolution
The domain needs to be managed and reconfigured.
How to Manage / UnManage domain servers:
The management state of individual objects can be set by attaching the Domain Manager Administration Console to the Failover Manager and using the Manage and Unmanage options.
To set the management state of an object:
1.) Open the Domain Manager Administration Console and attach to the Failover Manager 2.) Select the InChargeServices (in this case select the InCharge Service related to Smarts iP domain) whose objects you want to Manage or Unmanage. 3.) Right-click on a service and select Manage to poll the service so the Failover Manager will start monitoring this service. Unmanage will stop polling the service so the Failover Manager stops monitoring the service. 4.) After Manage/ UnManage operation, perform a reconfigure operation on the failover manager, this will create an instrumentation for the InChargeService and it will get monitored by the failover manager.