Smarts IP/SAM: Failover is not sending emails: Emails are not being sent from the Failover Manager or noted in the log file for the Failover Manager.
book
Article ID: 331787
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
The email function to send emails from the Failover Manager is a valuable tool to notify users if there is a change in domain status or if actions complete or fail.
Emails are not being sent from the Failover Manager or noted in the log file for the Failover Manager.
Environment
VMware Smart Assurance - SMARTS
Cause
Provided you can send emails from the command line prompt of your Operating System, Linux or Windows, then the settings in the failover.conf file need to be checked and validated for the MailSender, MailServer and MailRecipient .
Resolution
The MailSender, MailServer and MailRecipient need to be set up with valid user and server information for your Organization.
Check the following file for these settings: /smarts/local/conf/failover/Failover.conf file for the Mail settings after the comments section of the file.
The following is an example of correct settings, use the format that is appropriate for your email server. SettingSection { MailSender = "[email protected]"; MailServer = "mailhostxxx.emc.com"; MailRecipient = "[email protected]";
## Optional Parameters # # MailLevel = "ALL";
The default MailLevel is all so there is no need to uncomment this line unless you want to use a different parameter, see the comments section in the failover.conf file
Additional Information
When testing, we found that the Failover Manager log will not log any messages like the one below if the MailSender is not a valid user on the MailServer.
...Failover-monitor.asl: Sending email from valid.user1@emc.com to first1.last1@emc.com first.last@emc.com for failover-IP-SM93 (rh63-failover-2) : Error during backup actions of server 'failover-IP-SM93': /bin/cp: cannot stat `/opt/Incharge93/IP/smarts/CEC_local:/opt/Incharge93/IP/smarts/local:/opt/Incharge93/IP/smarts//repos/icf/failover-IP-SM93.latest.rps': No such file or directory