Smarts SAM Global Console Does not Support Single Sign On (SSO) Integration
search cancel

Smarts SAM Global Console Does not Support Single Sign On (SSO) Integration

book

Article ID: 331783

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Currently the Smarts SAM console does not support direct Single Sign On (SSO) integration with LDAP or Active Directory or Linux RedHat IPA 


Environment

VMware Smart Assurance - SMARTS

Cause

The Smarts Global Console as installed on the client PC, currently uses an internal java coding to handle security and user access.

Resolution

The Smarts Global Console as installed on the Client PC cannot be integrated with SSO at this time.  An Enhancement Request has been submitted for the SAS Suite of Products including the Global Console.

The Smarts Web Console since it uses the browser function, the method of handling SSO is to have a Web Console wrapper.  So the user first needs to be logged into to the SSO session through the browser and then they will be authenticated and allowed to download the Web Console.  Professional Services can be engaged to assist setting up the Web Console wrapper.

See Related KB

490672 : Smarts SAM: Setting up SSO in Watch4net doesn't propagate the user information to Smarts. https://support.emc.com/kb/490672


Additional Information

Enhancement Request has been submitted to request SSO integration for Smarts Assurance Suite 
https://asdjira.isus.emc.com:8443/browse/ER-359