DiscoveryErrorInfoFromDASL, CLI error post successful discovery through SNMP
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DiscoveryErrorInfoFromDASL, CLI error post successful discovery through SNMP

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Article ID: 331775

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

Device has been successfully discovered through SNMP, but device still shows in the Smarts IP pending list with CLI error message for the "DiscoveryErrorInfoFromDASL" property in Device properties as shown in the following.

Environment

SMARTS - 10.1.x

Cause

CLI discovery has been enabled for devices like Nexus and Juniper. In this configuration, Smarts IP fetches neighboring device information to form the connection, which is done at the certification level. Even if all the information for discovery is collected through SNMP, this CLI-based probe will be executed as it was part of the certification and it is not usually recommended to avoid this probe. Along with the above error message, the device will be in the Smarts IP pending list entry.

Resolution

If you know the device has been successfully discovered through SNMP and you do not want to see the device in the pending list or the CLI error message, do the following:

  1. Open the Smarts IP tpmgr-param.conf configuration file for editing using sm_edit.
  2. Set the flag DisableCLIError to TRUE.
  3. Save the file and load the tpmgr-param.conf by the below command:
./sm_tpmgr -s <APM> --load-conf=tpmgr-param.conf
  1. Delete the device and rediscover the same device, and the CLI error message should no longer display with the DiscoveryErrorInfoFromDASL property as shown in the following: