Smarts IP Manager: Correct value is not reflected for Network Parameter; using sm_dumpsys to examine ports and network parameters
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Smarts IP Manager: Correct value is not reflected for Network Parameter; using sm_dumpsys to examine ports and network parameters

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Article ID: 331743

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


After the successful discovery of devices customer is not able to read correct value from MIB

For Example: If customer sees some traffic on device so it should be reflected for network parameter like discarded packets. dropped packets etc.

Customer sees:-
InputPacketBroadcastPct = 0
InputPacketBroadcastRate = 0
InputPacketDiscardPct = 0
InputPacketDiscardRate = 0
InputPacketErrorPct = 0
InputPacketErrorRate = 0
InputPacketNoErrorRate = 0
InputPacketQueueDropPct = 0
InputPacketQueueDropRate = 0
InputPacketRate = 0
InputPacketsQueuedRate = 0


Environment

VMware Smart Assurance - SMARTS

Cause

You are seeing the following behavior due to the Ports status being Down/DISABLED

Run the below command to, to examine the Ports and gather the network parameters:-

./sm_adapter -s <domain> --model=sm_dumpsys -Dipaddr=<device IP> utils/ic_dumpsys.asl >outPut.txt

Resolution

Smarts is working as designed, the issue is with device ports being Down or Disabled

Additional Information

Correct Output from ENABLED Ports:

InputPacketBroadcastPct = 2.09896E-05
InputPacketBroadcastRate = 0.020816
InputPacketDiscardPct = 0
InputPacketDiscardRate = 0
InputPacketErrorPct = 0
InputPacketErrorRate = 0
InputPacketNoErrorRate = 12.0783
InputPacketQueueDropPct = 0
InputPacketQueueDropRate = 0
InputPacketRate = 12.0783
InputPacketsQueuedRate = 12.0783