Smarts IP: Service crashed - following error found in the log "SIGTERM received at 1486100027, shutting down..."
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Smarts IP: Service crashed - following error found in the log "SIGTERM received at 1486100027, shutting down..."

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Article ID: 331741

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts IP service was found stopped, after restarting the service restarted correctly. What caused this service to stop?

The IP log shows, the system received a "SIGTERM" which shutdown the IP server

SIGTERM received at 1486100027, shutting down...

[February 3, 2017 5:33:47 AM GMT +911ms] t@1261434624 Registry shutdown thread PRIORITY () February 3, 2017 5:33:47 AM GMT
ICF_MSG-*-ICF_SAVESTART-PersistenceManager: save started

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[February 3, 2017 5:34:38 AM GMT +880ms] t@1261434624 Registry shutdown thread PRIORITY () February 3, 2017 5:33:47 AM GMT
ICF_MSG-*-ICF_SAVEFINISH-PersistenceManager: save finished

 


Environment

VMware Smart Assurance - SMARTS

Cause

The signal "SIGTERM" as a user interruption. However Smarts logs cannot gather OS/environment details to confirm which user provided this abnormal termination.

The logs only reveals several logins by various clients and one of them could have issued the interrupt. 

[February 3, 2017 5:33:43 AM GMT +786ms] t@2450515712 HTTP #2
SYS_MSG-*-LOGIN-Login by admin from root@byl158a010[X.X.X.X]:33491 session 52

[February 3, 2017 5:32:47 AM GMT +789ms] t@2450515712 HTTP #2
SYS_MSG-*-LOGIN-Login by admin from root@byl07074a001[X.X.X.X]:39594 session 50

[February 3, 2017 5:32:47 AM GMT +791ms] t@2452616960 HTTP #1
SYS_MSG-*-LOGIN-Login by admin from root@byl07074a001[X.X.X.X]:39595 session 51

Resolution

Please check your environment client activities

This is not a SMARTS issues, the product is working as designed.