Smarts IP 9.4 x Generating False Temperature Alerts on Nexus devices
search cancel

Smarts IP 9.4 x Generating False Temperature Alerts on Nexus devices

book

Article ID: 331669

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


An issue with the High Temperature Thresholds from the MIBs for some CISCO Nexus devices are not being set properly.
This has been discovered in Smarts IP:  9.4, 9.4.1 and 9.4.2 versions,

Smarts will by default use the MIB data to retrieve and set the High Temperature Thresholds according to the Vendor stated limits.  This reduces the need to manually configure the threshold for Temperature Alerts in Smarts.
 
See https://support.emc.com/kb/332115 This article explains how you can assign unique temperature thresholds in Smarts if needed.




Environment

VMware Smart Assurance - SMARTS

Cause

There is a bug in the custom group "NexusInterfaces" under the TemperatureSetting class.

Basically this particular device should be monitored through the MIBThresholds.  CISCO does provide the MIB output for the Nexus devices.  
But these MIBThresholds are not being exposed in the setting class "TemperatureSetting" and as a result, The configured thresholds are shifting and causing the False alerts..

Resolution

There has been a Patch request for 9.4 and 9.4.1 and 9.4.2 versions that will address this issue in the future

No ETA for this Patch release has been provided.