Smarts SAM: After failover, brcontrol output shows "PID 0" for services that are running
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Smarts SAM: After failover, brcontrol output shows "PID 0" for services that are running

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Article ID: 331656

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Restarting the Smarts SAM services after a fail-over, the service process IDs (PID) show up as 0 even though the services are running.
Since the PID of each service is not displayed, this implies Failover did not work correctly or at least did bring up the services correctly.

The following steps were completed for the failover setup:
  1. Stop failover service.
  2. Stop all the domain manager services.
  3. Stop broker service.
  4. Restart services in the opposite order.
After the above steps are completed, the brcontrol command output shows PIDs=0
 


Environment

VMware Smart Assurance - SMARTS

Cause

The following are the correct steps for the Smarts SAM failover setup:
  1. Stop failover service.
  2. Stop all the domain manager services.
  3. Stop broker.
  4. Remove the broker repository.
  5. Restart in the opposite order, and brcontrol will show the correct PIDs.
The above issue occurs if you do not remove the broker repository (step 4 above) after stopping the broker. If the broker repository is not removed, when you restart in the opposite order, brcontrol will display  PID=0 for all of the services.
 

Resolution

To address this issue, start the services in the opposite order as follows:
  1. Start brcontrol.
  2. Run the following command to delete all the Domain Manager services:
brcontrol delete_all_dm

Note: The above command is necessary because while stopping the services, the services are not removed. Only the state of the services are changed to DEAD.
  1. Start all the Domain Manager services.
  2. Start failover service.