Smarts IP: Domain log shows the following error "ASL-ERROR_INVOKE-While attempting to invoke operation 'compileDrivers' of object 'MR_Object::IPDaslRuntimeEnv'
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Article ID: 331648
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
When a new IP domain is started, we see the following error in the domain log:
[July 29, 2014 4:30:44 PM GMT+02:00 +429ms] t@9516 InCharge Framework ASL-W-ERROR_RULE_SOURCE-While executing rule set 'F:\InCharge\IP\smarts\rules\import.asl' ASL-ERROR_ACTION-While executing action at: ASL-CALL_STACK_RULE- RuleName: CALL_PARAMS, Line: 111 ASL-CALL_STACK_RULE- RuleName: CALL_OPERATION, Line: 33 ASL-ERROR_INVOKE-While attempting to invoke operation 'compileDrivers' of object 'MR_Object::IPDaslRuntimeEnv' CI-ESPEC-While attempting to locate file with search path "F:\InCharge\IP\smarts\local\", intermediate path "logs\dasl\" and final component "APM1.log" <SYS>-ENOENT-No such file or directory
Environment
VMware Smart Assurance - SMARTS
Cause
This error is from DASL framework, which states dasl folder cannot be located in logs directory .
Resolution
Check to see if the dasl folder exists in <Basedir>/IP/smarts/local/logs directory. The dasl directory exists by default, unless its been deleted.
If the dasl directory doesn't exist, please create a dasl folder under <Basedir>IP/smarts/local/logs and start the IP domain again. This will resolve the start-up error.