Smarts IP: Nexus xK device is not showing a cable connection to a non-Cisco Router
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Smarts IP: Nexus xK device is not showing a cable connection to a non-Cisco Router

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Article ID: 331644

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Topology information is not accurate

The Cisco Nexus Switch certification is created so that it will connect to Cisco network devices.  The certification needs to be modified to allow bridging to occur. The current certification reads:
# Cisco Nexus cevChassisN3kC3048TP1GE Switch
.1.3.6.1.4.1.9.12.3.1.3.1106 {
        TYPE = Switch
        VENDOR = Cisco
        MODEL = Nexus-C3048TP1GE
        CERTIFICATION = CERTIFIED
        DASLDRIVER = CiscoNexus
        CONT = Cisco-Nexus-VDC-CLI
        HEALTH = Nexus-Entity-EntSensor
        VLAN = Cisco-Nexus-Vlan
        NEIGHBOR = Cisco-Cdp

INSTRUMENTATION:
        Environment = CiscoEntityFRU:DeviceID
        Card-Fault = CiscoEntity:DeviceID
        CPU/Memory = CiscoNexus:DeviceID
        Interface-Fault = MIB2
        Interface-Performance = MIB2
        Port-Fault = MIB2
        Port-Performance = MIB2
}



Environment

VMware Smart Assurance - SMARTS

Cause

Need to modify the certification of the Nexus Device

Resolution

Check to see what network device it is connected to.  If it is connected to a Juniper ERX device, contact Support for updated info as at the time of writing this KB these device still didn't show a cable connection after performing the following actions. 

If your device is not ERX do the following:

1. Locate the sysoid for your Nexus Switch.
2. Navigate to <base dir>/IP/smarts/bin
3. as root open the oid2type_Cisco.conf - sm_edit ../conf/discovery/oid2type_Cisco.conf
4. Find the certification for your device.
5. Edit the certification by adding BRIDGE = Cisco under the NEIGHBOR line
6. Save and exit.
7. run sm_tpmgr -s <IP domain name> reloadoid
8. Rediscover both the Nexus device and the connected device.