Smarts IP: Discovery Error from DASL, SSH keys did not match error seen on Smarts running on Linux OS
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Article ID: 331616
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Discovery error alert for applicable device(s) that never goes away. Unable to successfully complete DASL discovery for a device.
1.) Discovery Error seen on Pending List (CLI Login Failure) including the following message seen for the DiscoveryErrorInfoFromDASL attribute for the problematic device:
2.) When checking the IP Manager DASL log (found in the <IPBASEDIR>/smarts/local/logs/dasl) you'll see a similar message for the affected device(s):
Environment
VMware Smart Assurance - SMARTS
Cause
Device(s) SSH key has changed due to an actual hardware replacement, but configured to keep the same ip address as a device that has previously already been discovered by Smarts IP Manager.
Resolution
To resolve the issue do the following:
1.) Login to the Smarts IP Manager server as root. 2.) Open the /root/.ssh/sshhostkeys for editing. 3.) Remove the line containing the ip of the device encountering the issue and that you wish to update. 4.) Save and exit the file. 5.) Attemp a re-discovery of the device encountering the issue.
Additional Information
1.) DASL Debug is not required to detect this issue. 2.) The domain log will not show any indication of the issue.