Smarts IP 9.2.1.x takes a long time to discover CISCO 6509 that are configured with numerous VLANS
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Smarts IP 9.2.1.x takes a long time to discover CISCO 6509 that are configured with numerous VLANS

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Article ID: 331604

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


For IP version 9.2.1.x only:  

Customers trying to discover CISCO devices like the CISCO 6509 Switch that are configured with a large number of VLANs will find that the Discovery times on the IP domain will increase significantly.

Additional symptoms are that with the discover debug enabled, the log file will appear to wait after reporting Starting VLAN walks.  The log may also report Loop detected.
 

[2016/02/24 17:32:16 +213ms] t@1717548800 Discovery #3
AD_MSG-*-AD_LOG-at 'ProbeClosure t@1717548800', while discovering 'kaiser-co1191-2976337e005.d18.mso.mci.com', invoking Bridge-Probe

This probe has started and printed the below 2 data in the log:

[2016/02/24 17:32:16 +234ms] t@1717548800 Discovery #3
ASL_MSG-*-ASLP-discovery/ic-cisco-vlan-br-stp.asl: *** DEBUG *** ic-cisco-vlan-br-stp.asl 2016/02/24 17:32:16 Start VLAN Bridge Probe with Community: Switch: device.a.com

[2016/02/24 17:32:16 +234ms] t@1717548800 Discovery #3
ASL_MSG-*-ASLP-discovery/ic-cisco-vlan-br-stp.asl: *** DEBUG *** ic-cisco-vlan-br-stp.asl 2016/02/24 17:32:16 Starting VLAN walks for the device Switch::device.a.com[ 1717548800 ]



There are several contributing issues for this scenario.  

First, the CISCO 6509 is not certified in 9.2.1.x Versions.   Th

Environment

VMware Smart Assurance - SMARTS

Cause

The default ic-cisco-vlan-br-stp.asl script is not able to break out of the loop created by the snmp agent responses

Resolution

This issue has been resolved in versions 9.2.2.x and newer.

Recommendation is to upgrade to 9.3.0.x or newer to resolve the certification issue as well an upgraded ic-cisco-vlan-br-stp.asl that is able to detect and break out of the loop that is causing the delays in discovery.