Incorrect BGPSession Down or Disconnected notifications seen for Smarts Network Protocol Manager
Environment
SMARTS NPM 10.1.x
Cause
BGPSession status is generated by SNMP polling the BGP4-MIB, specifically bgpPeerState:
bgpPeerState OID: .1.3.6.1.2.1.15.3.1.2
Resolution
If you believe that the BGPSession is actually established, even though Smarts is reporting the BGPSession as Down/Disconnected, you can check the OID of the bgpPeerState as follows:
Browse to the NPM installation directory: <SMARTS>/NPM/smarts/bin
Enter the following command:./sm_snmp -c <community> -d <device-ip> walk .1.3.6.1.2.1.15.3.1.2
Values: 1 : idle 2 : connect 3 : active 4 : opensent 5 : openconfirm 6 : established
If the value returned is 6 (established), then the BGPSession is established and it may be necessary to open a case with Broadcom Support to investigate further why Smarts NPM is reporting the BGPSession as Down or Disconnected.