To clarify and provide a resolution for the customer
Symptoms: Customers may notice that the Sentinel Management tab inside Interconnect is missing or not appearing in their HCX Connector
Cause
This can be caused by
The OSAM service not being added in both the Compute Profile and Service Mesh
The wrong type of HCX manager is deployed to the source side
Resolution
Ensure the OSAM service is added in both the Compute Profile and Service Mesh. After the Service Mesh is reconfigured, the Sentinel Management tab should appear in Interconnect
Verify that the HCX Connector (source) was deployed from the link provided by the HCX Cloud
Redeploy the SGW/SDR appliances and verify there are no errors in the SGW/SDR logs
Check the state of SGW/SDR to ensure it is healthy
Impact/Risks: This is expected behavior when the OSAM service is added only to the Compute Profile and not the Service Mesh. Once the OSAM service is also included in the Service Mesh, this will allow HCX to install an SDR (Sentinel Data Receiver) and SGW (Sentinel Gateway). The SGW is deployed at the source and used to receive replication data from a source non-vSphere workload. The SDR is deployed at the destination to receive the replicated data.