VMware Aria Operations (SaaS) usage is beyond the subscription limit
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VMware Aria Operations (SaaS) usage is beyond the subscription limit

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Article ID: 331416

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

In paid versions of VMware Aria Operations (SaaS), customers have to pay overages (on-demand pricing) if objects under management go beyond the subscription limits.  In order to avoid overages, follow the steps mentioned in the Resolution section.

Symptoms:

  • The paid version of VMware Aria Operations (SaaS) (formerly known as vRealize Operations Cloud) usage is beyond the subscription limit and overage is being charged.



Environment

VMware Aria Operations (SaaS)

Cause

Overage charges will occur if the monitored objects count is greater than the subscription limit.
Depending upon your license, verify your current usage via one of the following out of the box dashboards:
  • VMware Aria Operations (SaaS) Billing 
  • VMware Aria (SaaS) Universal Billing

Resolution

In order to avoid overages, There are several options that can be used.  Choose one of the following options.
 

 

Placing Objects in Maintenance State

The following steps are only applicable to PAID VMware Aria Operations (SaaS) subscription models.

In order to automatically put newly discovered objects in a maintenance state, the following steps can be used.

  1. Navigate to the the Configure > Maintenance Schedules page, and click Add to create a new maintenance schedule.
  2. Provide a Schedule Name and Time Zone.  Next, set the Start on time as desired, and set the Stop on time to a large value, then click Save.
  1. Navigate to Configure > Policies and click Add to create a new Policy.
  2. Provide a Name and click Create Policy.
  3. Click Capacity.
  4. In the Select Object Type field, choose a desired object type like Virtual Machine.  Unlock Maintenance Schedule and select the maintenance schedule you just created, then click Save once done.
Note: Repeat this step for other newly discovered object types you want to place into a maintenance state, such as Host Systems.
  1. Navigate to EnvironmentCustom Groups and click Add to create a new group.
  2. Provide a Name, set the Policy to the policy you just created, and define the membership criteria for the objects you want to be place into a maintenance state.
Example:  Using the configuration shown below, any Virtual Machines with a name containing "TestUbuntu" will be placed into this group, which in turn will place them into a maintenance state.


All objects satisfying the custom group criteria will be placed into a maintenance state within 20 minutes of discovery.
Verify that the objects which are in maintenance state are excluded from VMware Aria Operations (SaaS) billing by reviewing the billing dashboards mentioned in the Cause section.
 


Stop Adapter Instances

The following steps are applicable to TRIAL or PAID VMware Aria Operations (SaaS) subscription models.

Adapter instance that are of low importance can be stopped, thus reducing the object count by the number of objects in that adapter instance. 
Note: no data will be collected on the child objects while the parent adapter instance is stopped.

Top stop an adapter instance, complete the steps below.

  1. Navigate to Data Sources > Integrations.
  2. Click the vertical ellipsis next to the adapter instance you want to stop, then click Stop Collecting All.

 

Create a Subscription Threshold Alert

Creating an alert to trigger, when the usage is close or already reached the configured subscription threshold, will help to identify potential subscription issues only.  To resolve the issue, use one of the other options detailed in this article.

Identify your subscription limit from the VMware Aria (SaaS) Subscription Manager service.  Note the total quantity of the subscriptions and if they are OSI or CPU based.

Note: OSI based metering is for vROps Cloud stand-alone subscriptions and CPU based metering is for VMware Aria (SaaS) Universal.

  1. From VMware Aria (SaaS), navigate to the VMware Aria Operations service, then ConfigureAlerts > Alert Definitions page.
  2. Click Add to create a new Alert Definition.
    1. Set the alert Name.
    2. Set the Base Object type to Container > Universe.
    3. Under Advanced Settings set Impact to Risk and Alert Type & Subtype to Administrative : Capacity.
  3. Click Next, click Symptoms, then click Create New Symptom.
    1. Depending on whether the subscription is OSI or CPU based, find and double-click on the metric Billing Objects > Summary > Total CPU Count or Total OSI Count.
    2. Set the symptom definition Name.
    3. Set Condition to is greater than.
    4. Set Value to the desired threshold to fire the alert.
Notes:
  • You may choose to set the subscription limit as a threshold, which has been fetched from the VMware Aria (SaaS) Subscription Manager service mentioned above.  If you'd like to get a proactive alert when the usage comes closer but does not hit the subscription limit, you may set the threshold to 10% or 20% less number than the subscription limit.  You may also choose to have two or more Symptoms in the same alert with different thresholds and criticality.
  • Each time when a new subscription has been added or the old one has expired, this field should be updated accordingly per the subscription limit shown in the VMware Aria (SaaS) Subscription Manager service.
  1. Set the criticality per your preference.
  2. Under Advanced Settings set the "Wait Cycle" and "Cancel Cycle" to 1
  1. Click Create.
  2. Find the newly create symptom in the right panel and drag and drop it to the left panel.
  3. Click Next., then click Next again.
  4. Select a policy to enable this alert in.  You may choose the default policy.
  5. Click Create.



Additional Information

See VMware Aria Operations (SaaS) trial usage is beyond the subscription limit (85084) if your version of VMware Aria Operations (SaaS) is in trial mode.