Smarts NCM: HTTPD stopped; unable to restart service; received "could not bind to address 0.0.0.0:80" message
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Smarts NCM: HTTPD stopped; unable to restart service; received "could not bind to address 0.0.0.0:80" message

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Article ID: 331334

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Unable to restart HTTPD service after unexpected failure.

ns1 ~ # service httpd status
httpd is stopped
ns1 ~ # service httpd start
Starting httpd: (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]


Environment

VMware Smart Assurance - NCM

Cause

As per the error message, port 80 is occupied on the server by some other service or apache service didn't shutdown gracefully/stale entry, hence apache is not starting up.

Resolution

There are 2 ways to resolve this issue / clear the port 80 -
1) Manually kill the process on port 80 using below steps (or)
2) Restart the server.

Steps to kill the process on port 80 manually -
Ex:
ns1 ~ # netstat -ltnp | grep ':80'
tcp 0 0 :::80 :::* LISTEN 4019/httpd 
ns1 ~ # kill -9 4019
ns1 ~ # netstat -ltnp | grep ':80'
ns1 ~ # service httpd start
Starting httpd: [ OK ]
ns1 ~ #