Unable to launch or login to GUI fails after fresh installation or upgrade.
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Unable to launch or login to GUI fails after fresh installation or upgrade.

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Article ID: 331331

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

Users would encounter difficulties trying to launch/log into the GUI when upgrading from a previous NCM version to any other higher version or performing a new installation on the same host where the previous version was installed and uninstalled. Usually observed issue:
  • Sometimes it will appear that the Java screen is processing and downloading.
  • Sometimes it will fail immediately after the Java screen has processed. 
  • Error of "Unable to Load Resource..." on the client.
Error message observed:

com.sun.deploy.net.FailedDownloadException: Unable to load resource: file:/C:/Users/<userID>/Downloads/$$codebase/startup.jar
    at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

or 

com.sun.deploy.net.FailedDownloadException: Unable to load resource: https://#.#.#.#:8880/voyence/lib/commons-collections-3.1.jar
    at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
 
or 
 

JNLPException[category: Launch File Error : Exception: null : LaunchDesc: <jnlp spec="1.0+" codebase="https://#.#.#.#:8880/voyence/">

<j2se version="1.8*" href="http://java.sun.com/products/autodl/j2se" initial-heap-size="128m" max-heap-size="512m" java-vm-args="-Xincgc"/>
    <property name="jnlp.netbeans.user" value="ncm"/>
    <property name="jnlp.netbeans.mainclass" value="org.netbeans.core.startup.VoyenceMain"/>
    <property name="jnlp.org.netbeans.ProxyClassLoader.level" value="1000"/>
    <jar href="startup.jar"/>

 
 

Environment

NCM 10.1.x

Cause

This is caused by the client machine caching the old jnlp/jar files.

Resolution

  1. Clear the Java cache on the client machine by doing the following:
    • In Start Menu, type "cmd"
    • At the command prompt type "javaws -clearcache"
  2. Reboot the client machine
  3. Log into the UI and download a new jnlp file from the server. 

NOTE: The actions listed above must be taken on Citrix Server if the GUI is started from the server.

If you have tried the previous methods and your problem still persists, please open a new support request (SR) with Technical Support referencing this KB article (331331).