Smarts NCM: Excessive logging seen in commmgr logs; High CPU usage seen on combo or device server
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Smarts NCM: Excessive logging seen in commmgr logs; High CPU usage seen on combo or device server

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Article ID: 331301

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


The product or environment functions and operations that may be affected include:
  • High CPU usage from commgrd process in Smarts NCM environment
  • Overall decrease may be seen in system performance for Smarts NCM environment


The following conditions, events and system behaviors may be observed with this issue:
  • Excessive logging is seen in commmgr logs related to Smarts NCM cutthru to a device.
  • Errors similar to the following may be seen in the commmgr log:
-382739568/cutthru(104780606651248@30006)#1: option read failed: Success

-382739568/cutthru(104780606651248@30006)#1: option read failed: Failed



Environment

VMware Smart Assurance - NCM

Cause

This is normally caused by some sort of memory issue that results in a command getting thrown into an endless loop.

Resolution

To address this issue, run a service restart on the device server that is trying to perform the cutthru. If you are running Smarts NCM on a combination server, you will need to restart services on the combination server.

To restart the service on your Smarts NCM combination or device server, do the following:
  1. In Linux environments, source the Voyence.conf file with the follwing command (not necessary for Windows environments)
source /etc/voyence.conf
  1. Restart the vcmaster service as follows (depending on your environment):
    • Linux:
service vcmaster restart
  • Windows: 
[Product directory]\bin directory\ncmmaster.pl restart