Smarts NCM: cannot pull configuration for many devices; "pull all" failing with different errors
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Smarts NCM: cannot pull configuration for many devices; "pull all" failing with different errors

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Article ID: 331289

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


The "pull all" is failing for many devices, this includes Cisco IOS Routers, Switches, Nexus devices and more. 

There is no one consistent error seem either but some of the errors include:

05897)#4: RESULT: Device does not support CISCO-CONFIG-COPY-MIB; trying OLD-CISCO-SYSTEM-MIB
Oct 04 11:51:54 8372/pull(105897)#4: DASL: Pulling Running configuration via SNMP/TFTP SNMPV3
Oct 04 11:51:59 8372/pull(105897)#4: Touching file: C:\smarts-ncm\data\devserver\cm\devxfr\1989-0.pull
Oct 04 11:56:59 8372/pull(105897)#4: DASL: transfer failed: RTSNMPVar::setSNMPValue: SNMP-SET Failed: SNMP++: SNMP request timed out (RTSNMPVar.cpp#747)
Oct 04 11:56:59 8372/pull(105897)#3: ERROR: Timeout setting 


or the following : 

ERROR: Terminal communications not configured

Environment

VMware Smart Assurance - NCM

Cause


In this case, the Account and Privilege password are missing for these devices as can be seen in the Properties->Communication tab of the device:
 

Resolution

1. From the Communications tab, select Update Credentials OR
2. if you want to select multiple devices, you can highlight them, then right click-> Update Credentials:
 
3. Fill in the correct mechanism, Account credentials and Privilege password and select 'Save Only'

4. Once this is saved, select one device and Pull All to check its working. 
5. Once complete, select all devices whose credentials have been updated and run a Pull All
6. All selected devices should complete successfully.