This Article explains how to enable Health Check monitoring in Smarts NCM so that it is easier to see if an NCM server is functioning.
Heath Check tab in the Smarts NCM System Management Console is not active.
The following message displays when the Health Check tab is clicked:
The Healthcheck service is not running.
Environment
NCM - 10.1.x
Cause
By default, Health Check monitoring is not enabled within the Smarts NCM product line.
So when you first login to the System Management Console, the Heath Check tab is not active and must be enabled as described below.
Resolution
To enable Health Check monitoring in Smarts NCM, do the following:
In the Smarts NCM System Management Console, click the Health Check tab. The following message displays (along with the steps to start the service):
The Healthcheck service is not running.
Complete the following actions depending on your environment:
To start the Smarts NCM Healthcheck service in Linux.
Login as root user.
Change directories (cd) to the following:
[Smarts NCM Product Home]/Healthcheck
Enter the following commands in sequence:
install.pl
cd/etc/init.d
./healthcheck start
Additional Information
The Smarts NCM Health Check utility verifies that the communication between the NCM application server and device server is functioning correctly, and that the device server is processing jobs.
If the round-trip check does not complete within a configurable threshold, an email, webpage update, or SNMP event is generated (the event type depends on the configuration).