Smarts NCM: How to change timeout value of health check
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Smarts NCM: How to change timeout value of health check

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Article ID: 331279

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


To adjust the timeout value used for Smarts NCM health check
This article explains how to increase or decrease the timeout value used by Smarts NCM for Health checks.

Errors similar to the following may be seen in the Smarts NCM Healthcheck.log file indicating a timeout has occurred:
ERROR: Task 0113675027710000 failed to complete on device server <DEVICE_SERVER_IP> (<DEVICE_SERVER_IP>) within the 300 second threshold

 


Environment

VMware Smart Assurance - NCM

Cause

This timeout may be occurring because of a problem with the Smarts NCM device server in the environment or because of network latency that is normal for the environment.

Resolution

If you encounter this issue, do the following:
  1. Determine the cause of the timeout and do either of the following:
    • If the timeout is caused by a problem with the Smarts NCM Device Server, investigate and resolve that issue.
    • If the timeout issue is caused by normal network latency, you can adjust/increase the Health Check timeout value as specified in the following steps.
  2. For Linux environments, execute the following command to set the voyence.conf file as source (this step is not necessary in Windows Server environments):
source /etc/voyence.conf
  1. Change (cd) to the Smarts NCM/Voyence Healthcheck directory:
Linux:
cd $NCM INSTALL DIR/Healthcheck

Windows
cd $NCM INSTALL DIR\Healthcheck
  1. Open the healthcheck.conf file for editing.
  2. Find the line for THRESHOLD='300' (300 is the default configured value).
  3. Change/increase the value to the desired timeout value in seconds.
    • The default threshold of 300 seconds equals 5 mintues.
  4. Save and close the healthcheck.conf file.
  5. Restart services on the Smarts NCM Application Server to apply the new threshold setting in the active environment.




Additional Information

If you are looking for how to enable the health check please see article: 167065: Smarts NCM: How to enable Health Check monitoring.