Smarts NCM: Autodiscovery not working despite correct credentials supplied, shows "No Valid Credentials"
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Smarts NCM: Autodiscovery not working despite correct credentials supplied, shows "No Valid Credentials"

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Article ID: 331272

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Autodiscovery of device is not working in NCM despite correct credentials being supplied and errors in the autodisc.log file show:

Jul 04 12:43:29 :1902639424#8: !!! No Valid V3 Credentials, check SNMP V3 Credential parameters
Jul 04 12:43:29 :1902639424#8: ---- Device did not respond to SSH  authentication
Jul 04 12:43:29 :1902639424#8: !!! SSH Credentials are not Valid
Jul 04 12:43:29 :1902639424#8: ---- Device did not respond to telnet  authentication
Jul 04 12:43:29 :1902639424#8: !!! telnet Credentials are not Valid
Jul 04 12:43:29 :1902639424#8: !!! Could not discover credentials for device

Jul 04 12:43:34 :1906837824/10.8.94.214#3: ERROR: termConnect: Login Failed
Jul 04 12:43:34 :1906837824/10.8.94.214#3: ++++++++++++++++++++
Jul 04 12:43:34 :1906837824/10.8.94.214#3: ...tdlib/stdterm.inc#1966: ERROR: termConnect: Login Failed


Environment

VMware Smart Assurance - NCM

Cause

The FQDN (Fully Qualified Domain Name) of the Device Server was missing from the Device Server's Lockbox. 

Resolution

Please follow the directions below to resolve the issue:
  1. On the Application Server do the following: 
    1. source /etc/voyence.conf.
    2. Run: $VOYENCE_HOME/bin/cstdriver -lockbox $VOYENCE_HOME/data/lock.clb -passphrase <passphrase> -addHost <FQDN of the Device Server>
    3. Copy the lock.clb file from the $VOYENCE_HOME/data directory on the Application Server to the remote Device Server and place it in the $VOYENCE_HOME/data directory of the Device Server. 
                          For example: scp lock.clb Host_Device_Server:/root/
  1. On the Device Server do the following:
    1. source /etc/voyence.conf
    2. Copy the lock.clb file from the /root/ directory and place it in the $VOYENCE_HOME/data directory
    3. Unlock the lockbox by running the following command: $VOYENCE_HOME/bin/cstdriver -lockbox $VOYENCE_HOME/data/lock.clb -passphrase <passphrase>
    4. Restart the vcmaster service on the device server by running: service vcmaster restart