Smarts NCM: Client console is not loading; 'Done Loading Modules' appears after login but console never starts
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Smarts NCM: Client console is not loading; 'Done Loading Modules' appears after login but console never starts

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Article ID: 331270

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Cannot login to Smarts NCM console from particular machines.

The following conditions, events or system behaviors may be observed with this issue:

  • Smarts NCM client console hangs after the login screen.
  • 'Done Loading Modules' appears in Smarts NCM client console interface, but application does not progress any further to start Smarts NCM.


Environment

VMware Smart Assurance - NCM

Cause

Java version is incorrect or java cache is damaged.

Resolution

To address this issue, re-install the correct java version on the client machine. This can be done as follows:
  1. On the client machines, stop the Smarts NCM client if it is still hanging and close all browser windows.
  2. Go to Windows Control Panel > Add/Remove Programs.
  3. Uninstall all versions of Java listed.
  4. Close the Control Panel.
  5. Open a new browser session and attempt to connect to the Smarts NCM server.
  6. When java is not detected, you will be prompted with a link to download and install the correct java version.
  7. Download and install java.
  8. Restart browser session once java is installed.
  9. Attempt to connect to Smarts NCM server and confirm that client starts successfully.