NCM Smarts: Status files are not getting deleted from all NCM device server's.
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Article ID: 331235
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Status files are not getting deleted from all NCM device servers.
Environment
VMware Smart Assurance - NCM
Cause
We have found that the logic in the Healthcheck.pl's processResults() function appears to have a bug in it. It's really not waiting as many seconds as we defined for THRESHOLD in healthcheck.conf file. Causing the Application Server at times is not to send Remove commands to the Device Servers. The result is the status_* files are left in data/appserver/pops/popIDX/syssync/commmgr/toServer folders on Application Server and data/devserver/pops/popIDX/syssync/commmgr/toServer folder on all the Device Servers.
Resolution
Please complete the following steps to resolve the issue.
Log into the Application Server via CLI with Root access
Source /etc/voyence.conf
Take a current backup of $VOYENCE_HOME/Healthcheck/healthcheck.pl file.
Edit the $VOYENCE_HOME/Healthcheck/healthcheck.pl file and update the line number 261 as if($count >= $limit) from if($count ge $limit).