Smarts NCM: SaveLogs.pl gets the following message: Error creating $VOYENCE_HOME/logs/logs-19_2_28-14-6-2016-all.zip
book
Article ID: 331234
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Customer receives the following: Error creating /opt/smarts-ncm/logs/logs-19_2_28-14-6-2016-all.zip when trying to run the following command.
- $VOYENCE_HOME/tools/saveLogs.pl all
Environment
VMware Smart Assurance - NCM
Cause
One of the logs that the SaveLogs.pl script is trying to compress is extremely large and can't process it.
Resolution
Please do the following:
- In NCM 9.4
- Review all the logs in the /usr/tomcat/apache-tomcat(version) and make sure none are large gigabyte logs.
- Review all the logs in the $VOYENCE_HOME/logs directory and make sure none are large gigabyte logs.
- Review all the logs in the $VOYENCE_HOME/ncmcore/logs directory and make sure none are large gigabyte logs.
- Review the server.postmaster file in the $VOYENCE_HOME/db/controldb/logs directory and make sure its not a large gigabyte file.
- In NCM 9.3
- Review all the logs in the /usr/tomcat/apache-tomcat(version) and make sure none are large gigabyte logs.
- Review all the logs in the $VOYENCE_HOME/logs directory and make sure none are large gigabyte logs.
- Review the server.postmaster file in the $VOYENCE_HOME/db/controldb/logs directory and make sure its not a large gigabyte file.
- Review all the logs in the $VOYENCE_HOME/jboss/server/vc-server/log directory and make sure none are large gigabyte logs.
When you find the massive file please do the following:
- copy it to another location that has plenty of space.
- confirmed that the copy was successful as you will clearing out the contents of the original file.
- run "cat dev/null > (file name)" to clear out the contents of the file.
- run $VOYECE_HOME/tools/saveLogs.pl all to confirm.
Feedback
thumb_up
Yes
thumb_down
No