Smarts NCM: Smarts NCM GUI does not display; JBoss service not starting; Error (powerup.log): Cant find the lockbox. Exception: java.lang.Exception: Key store file do not exist
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Article ID: 331231
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
The Smarts NCM GUI does not display and the JBoss service cant be started.
Errors from powerup.log file
DEBUG [com.powerup.common.util.CryptoHelper] (main) Unable to get the key from key store file Exception: java.lang.Exception: Key store file do not exist ERROR [com.powerup.common.util.CryptoHelper] (main) Error loading the lockbox ERROR [com.powerup.configmgr.server.services.admin.AdminServiceStartup] (main) The necessary Java Cryptography Extension files are not valid for the encryption algorithm. Refer to the installation document to fix the issue ERROR [com.powerup.configmgr.server.startup.ServerStartup] (main) Failed to start REQUIRED service - Admin Bootstrap
INFO [com.powerup.configmgr.server.startup.ServerStartup] (main) java.security.InvalidKeyException: No key given SHUTTING DOWN...
Environment
VMware Smart Assurance - NCM
Cause
The customer had installed new packages on the server and JBoss was no longer able to start due to changes to the linux groups file (/etc/group):
Resolution
The member of the cst group has been modified in the file /etc/group during the package upgrade and JBoss was no longer able to start due to missing members.
/etc/group is a text file which defines the groups to which users belong under the Linux OS. Multiple users can be categorized into groups.
The cst group had been changed from
cst:x:504:jboss,tomcat,root to cst:x:504:root
Once the jboss and tomcat users were re-added to the cst group and all the services restarted the issue was resolved.